Heartbleed Bug Update: No Risk

Written by Bill4Time Staff in News
April 10, 2014:

You now may have heard about the HeartBleed Bug. This is a serious vulnerability to internet security and only affects systems protected by OpenSSL. The bug allows attackers into the memory of the systems protected that include but are not limited to:

  • Emails
  • Instant messages
  • User name and passwords
  • Your sensitive data

Bill4time is not dependent on OpenSSL for security and as a result, Heart Bleed does not present a risk to our system and most importantly, your data.

Should you have any questions please feel free to contact our support team.

Written by Bill4Time Staff

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.